Follow

Si vous avez l'impression que les pour ne sont pas compatibles avec les dernières versions de Firefox , en fait elles le sont souvent, il suffit de chercher la page de l'extension (avec votre moteur de recherche préféré, mais pas sur le site de Mozilla qui ne montrera que les extensions officiellement compatibles), puis cliquer sur "télécharger le fichier". L'installation sera proposée, et avec un peu de chance ça fonctionnera.

(testé sur IceCat, un fork de Firefox)

@youen
Ça ne semble pas marcher avec Firefox Android, aucune application n'est listée en ouvrir avec.

@wallace ah, il faudrait que je teste pour voir. Avec ma version d'IceCat, le navigateur affiche tout de suite une popup proposant d'installer, sans même avoir besoin d'aller cliquer sur le fichier.

Ah mais je viens de voir que j'ai la version 68, qui serait encore compatible avec les extensions... Mais alors, pourquoi il me propose pas de les installer directement ? (aucun résultat dans la recherche, et bouton d'installation grisé sur la page des extensions)

Bon, en fait IceCat c'est mort apparemment comme projet. Pas à jour, donc pas de mises à jour de sécurité non plus.

Mon premier post ne s'applique qu'aux versions 68 ou précédentes de firefox. Sur ces versions, le site addons.mozilla.org ne permet plus l'installation des extensions, sauf via le bouton "télécharger le fichier".

Pour les versions plus récentes, en dehors des "extensions recommandées", c'est foutu ? Bonjour la régression. Quelqu'un y comprend quelque chose ?
@wallace

@youen
Ils ont fait le maj des plugins comme le version desktop y a 2 ans. Sauf que les devs se bousculent pas pour mettre à jour.

@youen
Et je comprends pas pourquoi ça ne serait pas compatible entre mobile et desktops puisque même moteur normalement

@wallace je crois que c'est pire que ça : les devs ne *peuvent pas* mettre leurs extensions à jour. Si j'ai bien compris.

@youen
Ha bon mais pourquoi ? Y a une sélection de ceux autorisé ?

@wallace et bien je découvre au fur et à mesure alors je ne suis pas sûr, mais si j'ai bien compris c'est Mozilla qui décide quelles extensions sont "recommandées", et ce sont les seules qui peuvent être installées.

@youen
J'avais un doute si c'est ça c'est pas du tout open...

@wallace
"In August 2020, Mozilla launched a new, reimagined Firefox for Android experience (codenamed "Fenix") [...]

Currently only a limited number of Recommended Extensions are supported on the release channel. We are continuously working on increasing support, taking into account usage and feedback to ensure we are making the most of our available resources [...]

If you are interested in Firefox for Android 68 and earlier (Fennec), please visit this article."

extensionworkshop.com/document

@wallace
"Recommended extensions differ from other extensions that are regularly reviewed by Firefox staff in that they are curated extensions that meet the highest standards of security, functionality, and user experience. Firefox staff thoroughly evaluate each extension before it receives Recommended status."

support.mozilla.org/en-US/kb/r

@wallace la façon dont je comprends ça :

les dev peuvent bien faire une extension compatible si ça leur chante, celle-ci ne pourra pas être installée sur firefox android, simplement car aucune interface ne permet d'y accéder ni d'installer un fichier téléchargé.

C'est le personnel de Mozilla qui choisit les extensions "recommandées", et seules celles-ci disposent d'une interface permettant leur installation.

Sauf si j'interprète mal ce que j'ai lu ?

@wallace je suppose, j'espère, qu'ils sont de bonne foi, et font leur maximum pour que tout fonctionne bien. Mais (encore une fois sauf si c'est moi qui comprend mal), j'ai l'impression qu'il y a une grosse erreur malgré tout ; la priorité aurait dû être de permettre aux dev des extensions de rendre eux-mêmes leurs extensions compatibles ET de permettre l'installation simple pour celles qui auront été marquées comme telles par leurs auteurs.

Et aussi, faire ce travail *avant* de sortir Fenix.

@wallace attention aussi à ne pas confondre "Fennec F-Droid" qui est une application (fork de Firefox) basée sur Fenix (la dernière version majeure de Firefox), alors que "Fennec" est le nom de l'ancienne version majeure de Firefox.

@youen
Mais c'est aberrant ! Pire que les store apple et google

Sign in to participate in the conversation
La Quadrature du Net - Mastodon - Media Fédéré

Mamot.fr est une serveur Mastodon francophone, géré par La Quadrature du Net.