Follow

Il y a qqs jours, mon smartphone a fêté ses 1️⃣0️⃣ ans 🎂🎉 (après vérification, j'ai retrouvé la facture et c'est pour le 15/10/2021 donc il n'a pas encore 10ans révolu ;-).
J'ai un @apple iPhone 4S depuis tout ce tps, acheté neuf à l'époque (inconscient que j'étais de pas mal d'enjeux). Je vous propose de faire un petit retour d'expérience et de voir les limites rencontrées 1/

Commençons par le matos , 1️⃣0️⃣ ans, 3 batteries, 1 vitre arrière et 1 écran. Sur ce modèle un kit de tournevis suffit pour faire ces répérations. Il est facile d'ouvrir ce téléphone avec 2 vis et grâce aux tutos @iFixitFR ou d'autres de procéder aux réparations. 2/

Donc après 1️⃣0️⃣ ans, tt fonctionne sans soucis (micro, haut-parleur, écran…), comme quoi pour ceux qui en doutent, l'électronique peut durer même avec quelques chutes au compteur, un plongeon de quelques secondes dans l'eau. Maintenant parlons logiciel , l'épine… : 3/

Ce téléphone est bloqué sur iOS 9.3.6 depuis des années, par le choix d'@apple et de ses équipes. C'est un modèle 32 bits, ainsi depuis maintenant qqs années, aucune app de l'@AppStore ne m'est accessible. Je ne peux que (ré)-installer les apps déjà achetées/installées. Mais… 4/

Combien d'applications j'ai vu afficher "Attention mettez à jour l'application sinon…" avec des patterns UX/UI très hétérogènes, pas du tout adaptés à gérer ce genre de situation. @apple et son écosystème ne le pousse pas, au contraire (mais les autres font-ils mieux ?) 5/

J'ai donc vu puis perdu l'usage de @ouisncf, fini l'achat de billets… dans un monde de + en + dématérialisé, compliqué. Heureusement l'app @SNCF, elle reste, fonctionnelle (import de billets) même si pendant des mois une popup empêchait d'utiliser l'app plus de 4 sec. 6/

Un appel serveur déclenchait la modale "mettez à jour l'app" qui envoyait sur l'@AppStore qui m'était inutile puisque je ne pouvais pas maj). Mode Avion le tps de saisir réf/nom du billet, puis reconnexion. Depuis peu, meilleur pattern, la popup peut être fermée. 🙏 @SNCF 😘 7/

Le téléphone est plutôt lent, on ne va pas se le cacher. Reste que pour mon usage (navigation internet, messageries, mails, agenda, 2fa, partage connexion) ca me suffit amplement. Le téléphone ne permet que la ce qui là encore me suffit. Je souris qd on parle , … 8/

Pas mal de sites font crasher/recharger le navigateur (safari/@firefox) lorsque la nuée de third-parties (, , etc.) se chargent. Heureusement, je peux stopper le chargement (lent) de la page et utiliser le mode 📖 qui donne accès à l'article/page sans le reste 9/

J'utilise @signalapp depuis très longtps et dernièrement, je me fais éjecter des groupes car je ne peux pas/plus maj l'app et celle-ci est nécessaire pour pouvoir converser en groupe ou échanger certains types de messages (ce dernier point reste possible via l'app desktop). 10/

Côté carto, Plans fonctionne mais j'ai perdu l'accès/l'usage de @transitapp (qui ne se lance même pas), @geovelofr (qui se lance mais est inutilisable), @ReseauCitiz ne fonctionne plus (crash au lancement) et bien d'autres applications. Web (mobile) impossible. 11/

Côté apps bancaires, ca commence à être de plus en plus limité. J'ai des alertes pour mettre à jour, mais les apps restent en partie fonctionnelles sur les versions que j'ai. Pourvu que ca dure d'autant plus avec le déploiement de la validation mobile pour accès/opérations. 12/

Plus généralement, les apps/sites (webmobile) gèrent mal le format de mon écran (petit - 3.5 pouces - par rapport aux nouveaux standards), donc parfois je ne peux pas accéder à des boutons/menus (il faut ruser… ou pas), idem "Progressive Enhancement / Graceful Degradation" 13/

Côté photo/vidéo, on ne va pas se le cacher, mes prises de vue n'envoient pas du rêve… mais ca m'évite de remplir mon disque.
Justement côté mémoire, 16 Go suffise puisque je ne prends que peu de photos, que j'ai de - en - d'applications, que je n'ai peu ou pas de musique. 14/

Point dur, l'accès à mon fournisseur de mail est devenu impossible depuis fin 2020 avec le passage à TLS 1.2 min., ce que ne permet pas iOS 9.3.6 (maj 10 minimum). Je n'ai pas d'autres apps/clients mails possibles (@AppStore KO). Je regarde du côté de docs.nginx.com/nginx/admin-gui 15/

Côté bonnes nouvelles, j'ai plein d'accessoires que mon entourage m'a donné en renouvelant leurs tél. Les pièces détachées sont peu chères. J'ai plein de propositions de tél. (6, SE…) par mon entourage car ils sont passés aux suivants et qu'ils ont pitié de moi, je résiste. 17/

Bref étant ds l'IT et motivé, je me suis adapté au fil du temps, c'est même devenu un défi. Reste que je comprends bien pourquoi la grande majorité des gens est contrainte à changer (norme sociale, marketing/publicité, obscolescence encouragée/programmée, "progrès", etc.). 18/

Les gds acteurs du numérique (privé) n'ont pas du tout intégré la longévité dans leur prisme de lecture, ni l'écosystème qu'ils génèrent ou qui les entourent. Dommage parce que l'électronique elle le permet, que les protocoles ouverts et standardisés depuis des décennies 19/

DNS, HTTP, TLS, SMTP, IMAP, POP… le permettent, aussi. Ils ont pourtant été pensés et développés il y a des décennies ! Reste que les couches hautes (système propriétaire/fermé, logiciel, modèle d'applications/store, opérateurs) ne l'intègrent pas, ne le poussent pas. 20/

Dans un monde de plus en plus contraint (énergie, ressources et plus globalement limites bio-geo-physiques planétaires), il est urgent de faire des choix : continuer à promouvoir un modèle peu/non durable et pas/non pensé pour durer ou questionner et revoir notre logiciel. 21/

Show newer
@fjg Pourquoi ne pas plutôt utiliser le site que l'application ? Je ne sais pas si firefox (enfin fennec, la version mobile) fonctionne sous iOS, mais il y a un plugin ([OUI léger]()) pour alléger le site (que j'utilise en version bureau).

@popolon @fjg je crois que sous iOS firefox est bridé (en tous cas sur l'iPad, j'ai téléchargé firefox mais on ne peut pas ajouter d'extensions, c'est bridé par Apple)

@fjg oops désolé, un bouton Shoutbox est présent sur pleroma au dessus du bouton valider et choix plaintext->Markdown, j’ai mal cliqué. donc, oui léger pour les mail il est sans doute possible d’installer un webmail perso (roundcube par exemple, en pensant à desactiver la correction orthographique qui envoie chez google) quelque part derrière un nginx,, et de configurer tls <1.2 pour ce site uniquement, derrière. C’est vrai que ça devient rare les site qui supportent <1.2, ils devraient au moins proposer cette mise à jour de sécurité. L’autre solution c’est d’avoir un firefox avec une libssl récente compilée en static, mais je crois qu’il est dur d’installer des applis qui ne viennent pas de leur store, contrairement aux Android. le mien, à 5 ans (je m’était fait volé le précédent), je ne reprendrait pas un Android derrière, je ne veux plus que du pure linux (pinphone probablement, en espérant qu’il mûrisse vite), je n’ai jamais dis d’accord à google pour quoi que ce soit, n’ai jamais utilisé leur magasin,; mais il aspire tout de même…

@popolon @fjg
Bravo pour ces presque 10 ans!
Pour ma part, je n'ai jamais acheté de mobile, toujours de la récup, mais plutôt régulièrement... car comme tu le dis il y a de la ressource!
Bon, pour mes 50 ans, ma mère m'a offert un FairPhone 2 tout neuf... 3 ans maintenant.

A propos des Iphone, j'ai récemment écrit à @gael pour comprendre pourquoi aucun Iphone n'était jamais pris en charge dans les distros alternatives comme /e/ lineage...

Car ce sont eux qui trustent le "back market"...

@popolon @fjg @gael
Je viens de découvrir le projet #sandcastle , cela m'a rappelé l'époque où on basculait des 3GS sous Linux... mais en perdant la fonction téléphone... 🤣

phonandroid.com/installer-andr

Sign in to participate in the conversation
La Quadrature du Net - Mastodon - Media Fédéré

Mamot.fr est une serveur Mastodon francophone, géré par La Quadrature du Net.