@Steve12L pas encore proposé même dans le canal béta pour moi.

@R1Rail Idem pour moi et comme gandi ne propose pas php 8 c'est dead pour le moment.

@ayoli Un poco si ! On va attendre et voir si ça arrive. Sinon je les contacterai mais ça va arriver je pense. Enfin j'espère. @R1Rail

@Steve12L Je ne sais pas si mon rpi aura la MàJ...
J'espère tout de même...
@ayoli @R1Rail

@Steve12L Dans mon cas c'est surtout que j'ai des wordpress sur le même serveur, et que même si la dernière version de WP est compatible php 8, pour les extensions et thèmes, c'est beaucoup moins sûr.

@R1Rail

@ayoli Ah oui effectivement, ça complique. On va être beaucoup à être emmerdés je pense. @R1Rail

@Steve12L @ayoli moi il est dans une jail à lui, je peux donc avoir un php différent (même si ça m'arrange d'avoir le même dans les différentes jails)

@Steve12L ah il faut php 8 ?
Dur, sachant que le 20 n'est pas compatible php 8, faut faire une mise à jour globale alors ?

@R1Rail Yep php 8. Oui MàJ globale, chez gandi on ne l'a pas encore php8 donc le problème est vite réglé.

@Steve12L espérons qu'ils vont sortir un 20 compatible php8 pour faire une transition. Mais bon perso je trouve que nextcloud grossi avec des fonctionnalités dont je n'ai rien à faire... Le groupware c'est pas dans mes besoins.

@R1Rail JE plussoie, je ne sais pas comment ils ont prévu ça, ça risque de gueuler pour beaucoup.

@R1Rail

Nextcloud 21.0.0 fonctionne avec PHP 7.

php --version
PHP 7.4.13 (cli) (built: Dec 12 2020 01:39:23) ( NTS )

@Steve12L

@gegeweb @R1Rail @Steve12L Ah l'article relayé par Steve parlait de ne plus supporter php 7 mais en fait là nextcloud.com/blog/nextcloud-h ils précisent que c'est php 7.2 et inférieurs qui ne sera plus supporté. Donc en effet php 7.4 c'est bon, ouf !

@ayoli Chez gandi on est en php 7.4 donc ça devrait le faire. On verra. @gegeweb @R1Rail

@R1Rail

Je viens de faire la mise à jour vers la 21.0.0.

Et ça fonctionne avec PHP 7.

Le journaliste raconte n'importe quoi ! ;)

@Steve12L

@ayoli

Comme y'avait un bug bien chiant dans la 20 à cause d'une dépendance, je suis sur la 21 depuis les beta.
Et ça tourne nickel…

J'ai juste les avertissement sur .well-known qui sont revenus.

Nginx est bien configuré !

@R1Rail @Steve12L

Sign in to participate in the conversation
La Quadrature du Net - Mastodon - Media Fédéré

Mamot.fr est une serveur Mastodon francophone, géré par La Quadrature du Net.