Besoin d'un petit coup de main en : je fais une mise à jour des paquets sur un raspberry pi 4, il reste bloqué depuis très longtemps sur cette étape:

>Paramétrage de raspberrypi-kernel (1.20210104-1) ...
>Suppression de « détournement de /boot/kernel8.img en /usr/share/rpikernelhack/kernel8.img par rpikernelhack »

Htop me dit que y'a zéro calcul en cours (mais un load à 7, contre 1 avant).

Que faire ? 😅

Donc cela fait maintenant 3 jours que ça tourne, toujours à 100% d'un CPU, mais 100% de wait (et un load à 7 au lieu de 6). Manifestement le processus n'avance pas et ne modifie pas les fichiers en question…
J'imagine que ça touche la partition /boot ?

Comment faire pour diagnostiquer à quelle étape ça coince ?

À défaut de mieux, vu que ça n'a pas l'air de réussir (à écrire sur la carte ?) est-ce qu'il possible d'annuler la mise à jour et de revenir à la version précédente ?

Vu que c'est sur le noyau, et que j'ai très peur de ne pas pouvoir démarrer ensuite, je préfère y aller doucement…

Non mais c'est une blague cette mise à jour…

Suite aux discussions (voir sous le reste du fil), j'ai récupéré une carte SD neuve, réinstallé une ancienne sauvegarde, je lance la mise à jour… et ça reste à nouveau bloqué là :
>Paramétrage de raspberrypi-kernel (1.20210108-1) ...
>Suppression de « détournement de /boot/kernel.img en /usr/share/rpikernelhack/kernel.img par rpikernelhack »

(pas la même version que la dernière fois donc, elle est plus à jour)

Pourrait-il y avoir un rapport avec le fait que le système vient d'un raspberry pi 3, que j'ai mis à jour (sous Debian Buster) puis migré sur le raspberry pi 4 ?

Un problème de noyau qui se mettrait mal à jour ?

@Lapineige euh rpi 3 n'est pas compatible rpi 4
Pas le même proc, hardware différent.... Bref...

Et je me suis amusé à upgrade une debian sur un rpi 3 -> l upgrade est passée en bousillant tout (retrait de paquet car plus présent en arm buster, etc)
Reinstall de buster sur un rpi 3 : ok
(Chhuuut oui j ai une debian arm... Mais mes deux archlinuxarm sont un charme à côté de ça ;))

Par contre une SD d un rpi 3 b dans un rpi b+ : la ca marche (avec un petit apt-get update/upgrade)

Follow

@lucius jusque là le passage du raspberry pi 1 au 2 puis du 2 au 3 n'a jamais posé problème... Le noyau a toujours géré (mise à jour comprises).

La mise à jour vers buster de raspian sur le raspberry 3 (d'un yunohost en plus) n'a pas posé de problème, c'était transparent.

@Lapineige woot, chaud qd meme vu les changements au fil du temps...

Bah moi un simple upgrade + dist-upgrade a destroy l os...
Genre j avais mariadb qui tournait... Bah plus de paquet installé... Mais les fichiers présents (mais corrumpus... Gné)
==> je suis reparti d une fresh install et depuis ca va ;)

Du coup, pas sur que ton souci soit pas lié "juste" à l upgrade... :(

Have fun en tout cas

Sign in to participate in the conversation
La Quadrature du Net - Mastodon - Media Fédéré

Mamot.fr est une serveur Mastodon francophone, géré par La Quadrature du Net.